RPC.IDMAPD(8) BSD System Manager's Manual RPC.IDMAPD(8)
rpc.idmapd — NFSv4 ID <-> Name Mapper
rpc.idmapd [-h] [-f] [-v] [-C] [-S] [-p path] [-c path]
rpc.idmapd is the NFSv4 ID <-> name mapping daemon. It provides func‐ tionality to the NFSv4 kernel client and server, to which it communi‐ cates via upcalls, by translating user and group IDs to names, and vice versa. The system derives the part of the string by performing a password or group lookup. The lookup mechanism is configured in /etc/idmapd.conf By default, the part of the string is the system's DNS domain name. It can also be specified in /etc/idmapd.conf if the system is multi-homed, or if the system's DNS domain name does not match the name of the sys‐ tem's Kerberos realm. When the domain is not specified in /etc/idmapd.conf the local DNS server will be queried for the _nfsv4idmapdomain text record. If the record exists that will be used as the domain. When the record does not exist, the domain part of the DNS domain will used. Note that on more recent kernels only the NFSv4 server uses rpc.idmapd. The NFSv4 client instead uses nfsidmap(8), and only falls back to rpc.idmapd if there was a problem running the nfsidmap(8) program. The options are as follows: -h Display usage message. -v Increases the verbosity level (can be specified multiple times). -f Runs rpc.idmapd in the foreground and prints all output to the terminal. -p path Specifies the location of the RPC pipefs to be path. The default value is "/var/lib/nfs/rpc_pipefs". -c path Use configuration file path. This option is deprecated. -C Client-only: perform no idmapping for any NFS server, even if one is detected. -S Server-only: perform no idmapping for any NFS client, even if one is detected.
rpc.idmapd recognizes the following value from the [general] section of the /etc/nfs.conf configuration file: pipefs-directory Equivalent to -p. All other settings related to id mapping are found in the /etc/idmapd.conf configuration file.
rpc.idmapd -f -vvv Runs rpc.idmapd printing all messages to console, and with a verbosity level of 3.
idmapd.conf(5), nfs.conf(5), nfsidmap(8)
The rpc.idmapd software has been developed by Marius Aamodt Eriksen ⟨email@example.com⟩.
This page is part of the nfs-utils (NFS utilities) project. Informa‐ tion about the project can be found at http://linux-nfs.org/wiki/index.php/Main_Page. If you have a bug report for this manual page, see ⟨http://linux-nfs.org/wiki/index.php/Main_Page⟩. This page was obtained from the project's upstream Git repository ⟨http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=summary⟩ on 2020-08-13. (At that time, the date of the most recent commit that was found in the repository was 2020-08-07.) If you discover any rendering problems in this HTML version of the page, or you believe there is a better or more up-to-date source for the page, or you have corrections or improvements to the information in this COLOPHON (which is not part of the original manual page), send a mail to firstname.lastname@example.org BSD February 3, 2003 BSD
Pages that refer to this page: nfs(5), nfs.conf(5)